
Using Sitelok with 
Webplus



Using Sitelok with Webplus

Copyright 2014-2016 Vibralogix. All rights reserved.
 
This document is provided by Vibralogix for informational purposes only to 
licensed users of the Sitelok product and is provided on an ‘as is’ basis 
without any warranties expressed or implied.

Information in this document is subject to change without notice and does 
not represent a commitment on the part of Vibralogix. The software 
described in this document is provided under a license agreement. The 
software may be used only in accordance with the terms of that license 
agreement. It is against the law to copy or use the software except as 
specifically allowed in the license.
 
It is the users responsibility to ensure the suitability of Sitelok before using 
it. In no circumstances will Vibralogix be responsible for any loss or damage 
of data or programs as a result of using Linklok. Your use of Sitelok implies 
acceptance of these terms.



Contents
.........................................................................Chapter 1 Introduction! 4
.........................................................................About this manual! 4
.........................................................................Chapter 2 Site settings! 5

..............................................................Using the .php extension! 5
.................................................................Disable BOM encoding! 6

.................................................Chapter 3 Securing a members page! 7
...........................................................................Securing a page! 7

.......................................................................Adding a logout link! 8
.......................................................Displaying user data in pages! 9

................................................................Chapter 4 Registration page! 11
..........................................................................Creating the form! 11

............................................................Add the form to your page! 11

............................................................Chapter 5 Update profile page! 13
..........................................................................Creating the form! 13

............................................................Add the form to your page! 13
....................................................................Chapter 6 Download links! 15

...........................................................................Storing your files! 15
..............................................................Creating a download link! 15

.......................................................Chapter 7 Pages with login forms! 16
..........................................................................Creating the form! 16

............................................................Add the form to your page! 16
................................................................................Chapter 8 Support! 19



Chapter 1 Introduction

About this manual

This manual  has been written to help users of Serif Webplus to integrate 
Sitelok in their projects. It is not meant to replace the main Sitelok Manual 
but really to explain Webplus specific  points. We assume that you have 
installed Sitelok on your server already and that it is working properly.

As Sitelok uses PHP you won't be able to test the functionality of your 
pages within Webplus. You must publish you site to test the pages.

We have written this manual based on Webplus X7 but other versions 
should have similar settings.

Please note that Sitelok normally requires pages to have the php 
extension. Most servers can be set to allow PHP to be used 
inside .html pages as well though. Ask your hosting company to 
enable that if you can't rename your pages to .php for any reason.
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Chapter 2 Site settings
Using the .php extension

Sitelok uses PHP so your pages ideally need to have the extension .php.  
Pages with the extension .php will  still work exactly like the .html pages and 
don't affect layout etc. You can rename existing pages to .php by selecting 
Page Properties in the Properties menu and adjusting the filename.

If you prefer you can set .php as the default extension for the site by 
selecting Site Properties in the Properties menu. Click File Naming in the 
Advanced section and select php and the Default page file extension.
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Many servers have an option allowing you to use PHP code directly in.html 
pages without renaming them. Normally this just requires a line to be added 
to your .htaccess file but check with your hosting company. This is useful for 
existing sites where you can't easily rename the pages.

Disable BOM encoding

For some reason Webplus has BOM encoding enable by default (at least in 
X7) so this needs to be disabled. This is an encoding method that is no 
longer used but can stop PHP working correctly on many servers. To 
disable BOM select Site Properties from the Properties  menu. Click 
Advanced and uncheck the Write Byte Order Mark to file checkbox.
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Chapter 3 Securing a members page
Securing a page

Sitelok can secure .php pages on your site by simply adding a code snippet 
to the very top of the the page telling Sitelok which usergroups have 
access.

First of all create the page you want to secure. To secure it select Page 
HTML Source from the View menu. At the top before the line that says <!--
Page Preamble--> paste in the following snippet.

<?php 
$groupswithaccess="CLIENT"; 
require_once("../slpw/sitelokpw.php"); 
?> 

This tells Sitelok to only allow access to members of the CLIENT 
usergroup. You can replace CLIENT with another group name or list 
multiple groups separated by commas.

Please note that the above code assumes that your page is in a folder. If it 
is in the root of your site then we need to adjust the relative path so use

require_once("slpw/sitelokpw.php");
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Adding a logout link

You can add a logout link to your site by creating a hyperlink that points to 

/slpw/sitelokpw.php?sitelokaction=logout

To do this just highlight the text or object you want to turn into a hyperlink 
and right click. Select Hyperlink... in the popup menu. Select the hyperlink 
type as Internet Page and paste in the link above.

In the target window tab select the Type as Same Window.
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Displaying user data in pages

Sitelok lets you display any data stored in the users record anywhere on the 
page. So for example you might like to display the users first name or email 
address. To do this simply use any of the following codes as required.

First name <?php echo $slfirstname; ?>
Last name <?php echo $sllastname; ?>
Full name <?php echo $slname; ?>
Email   <?php echo $slemail; ?>
Username <?php echo $slusername; ?>
Custom1 <?php echo $slcustom1; ?>
  for other custom fields replace the 1 in the code.

The easiest way to insert these codes in the page is to copy the code to the 
clipboard and then select HTML Fragment from the Insert menu. Draw the 
rectangle on the page where you want the data to appear and then click the  
Paste to Body button in the dialog.
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If you want to align the code to existing text you can right click the html 
code fragment and click Arrange - Attach to Text. In the dialog that appears 
select Position inline as character. This allows you to insert the data as part 
of a text box for example.
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Chapter 4 Registration page
A registration page is used to allow users to register for free access to your 
members area. If you are selling membership using a payment plugin (such 
as the Paypal  or 2checkout plugins) then you don't have to use a 
registration form as the user is added automatically after payment.

To create a registration form follow these steps

Creating the form

In the Sitelok control panel  go to Forms - Registration forms. Here you can 
either use an existing form or create a new one. The form designer allows 
you to design and style the form as well  as setting things like the usergroup 
to add the user to, the thankyou page and also the email to be sent out. 
When the form is how you want it click Save.

Although its usually straightforward the main Sitelok manual  explains how 
to use the designer in more detail.

It's also possible to write your own form code to use with Sitelok if you need 
to. The main Sitelok manual explains how to do that.

Add the form to your page

To generate the code to add to your page click  next to the form.

There are a few options for the generated code but unless you need to 
make custom changes to the form code you can just leave the defaults to 
embed the form in your page. You will  see the 3 steps to adding the code to 
your page as follows.

Step1
Copy the code to the clipboard. In Webplus select Page HTML Source from 
the View menu. At the top before the line that says <!--Page Preamble--> 
paste in the snippet.

Chapter 4 - Registration page

Page 11



Step 2
Copy the code to the clipboard and then in Webplus select HTML 
Fragment... from the Insert menu. Position and size the rectangle as 
needed on the page (you can adjust it later anyway). Click the Paste To 
Head button in the dialog.

Step 3
Copy the code to clipboard and then in Webplus click the Paste to Body 
button in the html fragment dialog.

When you publish the page you should see the form appear. As the form 
was embedded in the page any changes you make to the design in Sitelok 
should appear on the page immediately when saved without needing to 
publish the page again.
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Chapter 5 Update profile page
An update profile page allows the user to modify details that you store 
about them such as their password and email address.

To create an update form follow these steps

Creating the form

In the Sitelok control panel go to Forms - Update profile forms. Here you 
can either use an existing form or create a new one. The form designer 
allows you to design and style the form as well as setting an optional 
thankyou page and emails to be sent. When the form is how you want it 
click Save.

Although its usually straightforward the main Sitelok manual  explains how 
to use the designer in more detail.

It's also possible to write your own form code to use with Sitelok if you need 
to. The main Sitelok manual explains how to do that.

Add the form to your page

To generate the code to add to your page click  next to the form.

There are a few options for the generated code but unless you need to 
make custom changes to the form code you can just leave the defaults to 
embed the form in your page. You will  see the 3 steps to adding the code to 
your page as follows.

Step1
Copy the code to the clipboard. In Webplus select Page HTML Source from 
the View menu. At the top before the line that says <!--Page Preamble--> 
paste in the snippet.
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Step 2
Copy the code to the clipboard and then in Webplus select HTML 
Fragment... from the Insert menu. Position and size the rectangle as 
needed on the page (you can adjust it later anyway). Click the Paste To 
Head button in the dialog.

Step 3
Copy the code to clipboard and then in Webplus click the Paste to Body 
button in the html fragment dialog.

When you publish the page you should see the form appear. As the form 
was embedded in the page any changes you make to the design in Sitelok 
should appear on the page immediately when saved without needing to 
publish the page again.

Chapter 5 - Update profile page

Page 14



Chapter 6 Download links
Sitelok can secure download links as well  making sure that the location of 
the files on your server is not known and that they only worked for logged in 
users.

Storing your files

If you want to secure downloads using Sitelok you should store the files in 
the file folder created during installation. This will  have a name like 
slfiles_xxxx and won't be found by search engines, robots or hackers. You 
can find the folder name in Tools - Configuration - Download paths.

Creating a download link

You can add a download link in your page by using the following snippet.

<?php;siteloklink('testfile.zip',1);?>

To do this just highlight the text or object you want to turn into a hyperlink 
and right click. Select Hyperlink... in the popup menu. Select the hyperlink 
type as Internet Page and paste in the link replacing testfile.zip with your 
filename (no path needed). The extra ; after <?php is required as Webplus 
doesn't allow a space to be used here.
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Chapter 7 Pages with login forms
Sitelok has two ways for users to login. The simplest is the login form (login 
template) that appears if a user tries to visit a secured page and haven't yet 
logged in. The default login form that appears can be styled in Forms - 
Default Login form style or can be replaced by your own custom login 
template (see the main Sitelok manual for details).

Often the default login form is all that is needed as you can create a login 
link on your site that simply links to a secured page to force the login form 
to appear when necessary. However in some cases you may prefer to have 
a login form on one or more of your pages and this can be done as follows.

Creating the form

In the Sitelok control panel go to Forms - Login forms. Here you can either 
use an existing form or create a new one. The form designer allows you to 
design and style the form as well as setting optional  features such as 
captcha and forgotten password.. When the form is how you want it click 
Save.

Although its usually straightforward the main Sitelok manual  explains how 
to use the designer in more detail.

It's also possible to write your own form code to use with Sitelok if you need 
to. The main Sitelok manual explains how to do that.

Add the form to your page

To generate the code to add to your page click  next to the form.

There are a few options for the generated code but unless you need to 
make custom changes to the form code you can just leave the defaults to 
embed the form in your page. You can decide if you want users to be 
redirected on login (if their usergroup has a redirect URL set) or to stay on 
the page.  You can also set if you want the login form to be hidden when the 
user is logged in.

Step1
Copy the code to the clipboard. In Webplus select Page HTML Source from 
the View menu. At the top before the line that says <!--Page Preamble--> 
paste in the snippet.
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Step 2
Copy the code to the clipboard and then in Webplus select HTML 
Fragment... from the Insert menu. Position and size the rectangle as 
needed on the page (you can adjust it later anyway). Click the Paste To 
Head button in the dialog.

Step 3
Copy the code to clipboard and then in Webplus click the Paste to Body 
button in the html fragment dialog.
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When you publish the page you should see the form appear. As the form 
was embedded in the page any changes you make to the design in Sitelok 
should appear on the page immediately when saved without needing to 
publish the page again.
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Chapter 8 Support
Hopefully if you have followed this manual carefully everything will  be 
working fine. However sometimes things don’t go quite so smoothly so if 
you have any questions or problems then please check the FAQ on the 
support page or email us.

Support and updates for Sitelok are free of charge for one year after 
purchase. Shortly after purchase you should receive a username and 
password that provide you with access to the latest downloads, FAQ and 
other resources.

Support area: http://www.vibralogix.com/support/

Email: support@vibralogix.com
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